「あなたのサーバはPHPバージョン5.1.6を実行していますが、WordPress 4.7.8には少なくとも5.2.4が必要です」というエラー解決方法

急上昇中!
ブログランキングがんばってます^^
詳細はコチラから!!

自分の管理サイトにアクセスしたところ、エラーが表示されてアクセスできない状態となっていました。エラー表示は「Your server is running PHP version 5.1.6 but WordPress 4.7.8 requires at least 5.2.4.」

さっそく、解決の方法を備忘録としてまとめておきます。

 

エラー表示の経緯とエラーの意味

自分の管理サイトにアクセスしようとしたら英語表記で「Your server is running PHP version 5.1.6 but WordPress 4.7.8 requires at least 5.2.4.」というメッセージが出ていました。

利用環境としては、

  • ワードプレスを利用
  • エックスサーバーで利用
  • あまり更新していないサイト

英語に困ったときはグーグル先生の翻訳に頼ります。

グーグル先生によると「あなたのサーバはPHPバージョン5.1.6を実行していますが、WordPress 4.7.8には少なくとも5.2.4が必要です」と。簡単に言うと、バージョンアップしなさいってことですね。

 

エラー解消への解決策はPHPのバージョンアップ

WordPressの管理画面にすら入ることができない状態なので、まずはPHPのバージョンアップを行います。エックスサーバーの管理画面へアクセス。

「PHP Ver.切替」を選択します。(※PHPのバージョンを変える対象ドメインを選んでくださいね)

 

うーん、相当ほったらかしていましたね。個々のタブで変更したいPHPのバージョンを選択してください。

 

変えたいバージョンを選んだらボタンをポチッと。これで完了です。お疲れさまでした。

 

まとめ

PHPのバージョンアップを終わらせて、WordPressの管理画面にアクセスしてみると・・・ちゃんと表示されました。エラーとなっていたページも表示されるようになりました。

今回は新しく登場していたPHP7を選択しましたが、一部のプラグインは動作しない可能性もあるようです。後日、プラグインの動作確認方法もアップしますので、不安な方はそちらも確認してみてください。
「PHP7に変更してもプラグインはきちんと動作するのか調べてみた」

すぐにワードプレス自体のバージョンアップを行い、プラグインの動作もチェックしましたがまったく問題なし。少しサイトの読み込みが早くなったような気がします。(調べていません)

 

今回エラーを発見したのは、ある商品の売上げが突然止まっていたからでした。何かがおかしいなと思って原因を調べようとしたところアクセスできませんでした。そりゃ売上げがないのも当たり前です。

放置しているサイトでもWordPressで管理しているなら、たまに見に行かないとダメですね。反省。

 

管理人オススメ教材&ツール

コメントを残す